Issue
When a User enters the correct credentials into the improveit 360 Go mobile app, the login is successful, but re-routes the User back to the login page, instead of the app's Home display.
Product
improveit 360 Go
Resolution Steps
We recommend removing the Salesforce1 app from the User's mobile device.
Once the conflicting app is removed, the User should be able to login to i360 Go successfully.
Cause
If the User also has the Salesforce1 app downloaded onto their mobile device, they may
experience issues. The two mobile apps are not compatible.