Known Salesforce Issue (reported bug): The Inline Editing feature may be disabled for List Views when there are more than five (5) Lines of Filter Criteria or when you add Filter Logic. Reduce your Filter Criteria and/or remove Filter Logic, save your List View and try Inline Editing again.
For the Account object List Views specifically, you need to specify only one (1) Record Type for your List View if you plan to Inline Edit from an Accounts List View. Likely similar for other objects that utilize Record Type. See screen shot below. Filter your List View by Record Type and choose only one (1) Record Type for the List. This should allow you to Inline Edit fields on the Account object.
Cause
There are a variety of causes for the Inline Editing feature to be overridden or not functioning as you expect. If you have followed the Resolution Steps above and still believe the Inline Editing feature within your system is not functioning properly, open a Ticket with our Support Team. Please provide the Objects and names of List Views where you are trying to use Inline Editing.
Resolution Steps
Cause
There are a variety of causes for the Inline Editing feature to be overridden or not functioning as you expect. If you have followed the Resolution Steps above and still believe the Inline Editing feature within your system is not functioning properly, open a Ticket with our Support Team. Please provide the Objects and names of List Views where you are trying to use Inline Editing.