Issue:
When creating multiple Sales off of an Appointment, this error prompts when
attempting to save the new Sale:
"You must specify one of the following: Lead Source, Prospect, Appointment, or Sale"
Product:
Enterprise, Professional, Supportworks
Resolution Steps:
Workaround: Create the second Sale WITHOUT populating the Sales Rep fields.
The new Sale should then save successfully.
Then, edit the Sale and enter in the appropriate Sales Rep information.
Workaround IF Commissions do not need to be visible: Remove 'Read' permission from the Commissions object on the User's Profile. If Commissions are not visible, you can enter a Sales Rep on the Sale, different from the Appointment and the Sale record will save successfully.
Cause:
The system is looking back to the Appointment and matching the sales rep values with the
default value on the sale, if those values do not match the system rolls back and won't let
the user save the record. This is because the sale is looking to match the commission record
relationships to the same ones on the sale and if the sales rep on the sale doesn't match
what's on the appointment the data is in an unhandled state.