Symptom:
We are experiencing issues with notification messages from Salesforce going into users' junk folder. We've reported the messages as not junk, but this continues to occur.
Cause:
Your org is now part of what Salesforce calls Hyperforce, which has new security requirements. Check this site to see if your Instance is on Hyperforce: https://availability.salesforce.com/find-my-instance/
Salesforce no longer recommends IP allowlists, which is what you have most likely been using.
This article from Salesforce has a table with instructions for customers who are using certain features, like IP allowlists, and what you should do next.
https://help.salesforce.com/s/articleView?id=000392992&type=1
Salesforce is recommending that customers no longer use the IP allowlists, but instead "Use industry-standard email security mechanisms supported by Salesforce such as SPF/DKIM/DMARC."
Create SPF Record or DKIM Key for better Email Deliverability
This Salesforce article specifically discusses this change for Hyperforce customers. Ensure you can receive email from the Salesforce application: https://help.salesforce.com/s/articleView?id=000388992&type=1
According to this article, it states that you can CAN continue to use allowlists, and if you do, the IP ranges are included on this article, but as you mentioned, the IP examples that were given are not on this document.